Fix Travis CI builds

Description

Travis CI builds are failing with an error Expected feature release number in range of 9 to 14, but got: 8

This has something to do with a change on Travis CI end and Java 8 to build the project.

Suggested fixes:

  • Change the build image to use an older version of Ubuntu (Trusty)

  • Use openjdk8 instead of oraclejdk8

All of this is configurable in the .travis.yml file.

Oracle JDK 8 seems to be available in Trusty: https://docs.travis-ci.com/user/reference/trusty/#jvm-clojure-groovy-java-scala-images

While Xenial (the default distro) only includes OpenJDK8: https://docs.travis-ci.com/user/reference/xenial/#jvm-clojure-groovy-java-scala-support

This must have changed sometime after setting up the builds.

 

 

Status

Assignee

Unassigned

Reporter

Ken Dunlap

Labels

None

Additional Assignee

None

Priority

Medium
Configure